LearnDash is a course platform plugin that integrates directly with Wordpress.

💡 A Showit Advanced Blog subscription is required to use the LearnDash plugin.

⚠️ FOR ADVANCED USERS: LearnDash does work well on Showit but it does require some additional blog templates and additional plugins in order to have a fully functional membership site.

Below we'll detail the Showit blog template requirements.

Additional plugins like UnCanny Toolkit can help with additional functionality and reporting.

For full use of LearnDash, please refer to their own documentation.

Required LearnDash Blog Templates

LearnDash requires these blog templates within the Showit design in order to properly display content from LearnDash on the blog.

Custom Template Name in Showit

Function of Template

Required Wordpress Content Placeholders

Page (choose from template dropdown)

Used as a catch-all to display list of courses, user account, etc.

  • Post Content

  • Post Title (optional, suggested)

single-sfwd-courses

Display a Single Course

  • Post Content

  • Post Title (optional, suggested)

single-sfwd-topic

Display a Single Topic

  • Post Content

  • Post Title (optional, suggested)

single-sfawd-lessons

Display a Single Lesson

  • Post Content

  • Post Title (optional, suggested)

single-sfwd-quiz

Display a Single Quiz

  • Post Content

  • Post Title (optional, suggested)

Did this answer your question?