We are currently beta testing WooCommerce support for Advanced Blog subscriptions*. WooCommerce is a great solution for advanced users who like to DIY projects. We suggest Shopify Lite for a simple store solution.

WooCommerce's default output seems to be working well with our Showit theme. 

––––––––––––––––––––––––––

Give it a Try:

Requirement: Advanced Blog Subscription

  1. Update your Showit plugin to version 3.0.1 or newer for compatibility with WooCommerce. 
  2. Then install the WooCommerce plugin.

––––––––––––––––––––––––––

Things to Know:

  • Individual product pages will use the Single Post template for their layouts (sorry custom product template support is not available)
  • A 'Page' blog template is required for the Shop, Cart and Checkout pages to render correct. (see here)

*Requires an Advanced Blog subscription
***Showit does not offer support for setting up or operating third-party plugins, including WooCommerce. We also cannot be responsible for changes that the plugin developers release which may break compatibility with our Showit theme.
 

Tip: If you're looking for a simple store option we suggest Shopify Lite for embedding single item buy buttons directly onto Showit pages using our Embed Code widget or a Basic Shopify account to host a separate online store under a subdomain like shop.yourdomain.com

Did this answer your question?